联华证券_股指期货配资网_黄金期货配资_国家允许的配资平台
股指期货配资网
你的位置:联华证券_股指期货配资网_黄金期货配资_国家允许的配资平台 > 股指期货配资网 > 通达信云端多空共振主图指标公式(附源码破译和源码)

通达信云端多空共振主图指标公式(附源码破译和源码)

发布日期:2024-01-31 05:26    点击次数:200

编程思路破译

C2赋值:1日前的收盘价

BG赋值:如果(C2-收盘价)*100/C2>=2.3,返回1,否则返回0 OR 如果(开盘价-收盘价)*100/开盘价>=5,返回1,否则返回0

BG2赋值:如果(最高价-最低价)*100/C2>=3.58,返回1,否则返回0

BB1赋值:最低价< 1日前的最低价

SELL1赋值:BG AND BB1 

BR赋值:如果(收盘价-C2)*100/C2>=2.59,返回1,否则返回0 OR 如果(收盘价-开盘价)*100/开盘价>=4.5,返回1,否则返回0 OR 如果(收盘价-最低价)*100/最低价>5,返回1,否则返回0

当满足条件BR时,在开盘价和收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画红色

DAY1赋值:上次SELL1距今天数

JIA1赋值:DAY1日前的开盘价

JIA2赋值:1日前的开盘价

BB4赋值:收盘价>JIA2

BB2赋值:最高价>JIA1

BUY1赋值:BR AND BB2 AND BB4

DAY2赋值:上次BUY1距今天数

S1赋值:DAY1< DAY2

B1赋值:DAY2< DAY1

当满足条件S1时,在开盘价和收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画淡绿色

当满足条件B1时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画红色

当满足条件B1时,在开盘价和收盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,线宽为2,画红色

AA2赋值:成交额(元)/成交量(手)

BB3赋值:最低价< AA2*0.9

CC2赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100>1.2

DD2赋值:最低价< 收盘价的6日简单移动平均*0.921

DD1赋值:最低价< 收盘价的5日简单移动平均*0.921

EE2赋值:成交量(手)< 成交量(手)的5日简单移动平均*1.5

FF2赋值:BB3 AND CC2 AND DD2 AND EE2

当满足条件FF2时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR00FFFF

B4赋值:上次FF2距今天数

E4赋值:B4< 5

F4赋值:E4 AND 收盘价>1日前的收盘价

当满足条件F4时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR00FFFF

A2赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100< 1.02

A3赋值:最高价>收盘价的5日简单移动平均*1.12

AA赋值: A2 AND A3

当满足条件AA时,在最高价*1.06位置书写文字,画绿色

当满足条件AA时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORFF0000

VAR1赋值:4*(收盘价-5日内最低价的最低值)/(5日内最高价的最高值-5日内最低价的最低值)*100的5日[1日权重]移动平均- 3*(收盘价-5日内最低价的最低值)/(5日内最高价的最高值-5日内最低价的最低值)*100的5日[1日权重]移动平均的3.2日[1日权重]移动平均

VAR2赋值:8

CC赋值:VAR1上穿VAR2

CCC赋值:VAR1上穿VAR2 AND 最高价>1日前的最高价 AND 收盘价>1日前的收盘价 

当满足条件CCC时,在最低价*0.99位置画1号图标

当满足条件CC时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画红色

当满足条件CC时,在开盘价和收盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,线宽为2,画红色

CF1赋值:上次CC距今天数

CF2赋值:CF1< 3

CF3赋值:CF2 AND 收盘价>1日前的收盘价

当满足条件CF3时,在开盘价和收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画黄色

CD赋值:VAR2上穿VAR1

当满足条件CD时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画黄色

当满足条件CD时,在开盘价和收盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,线宽为2,画黄色

当满足条件CD时,在最高价*0.93位置书写文字,画红色

当满足条件CC时,在最低价*0.97位置书写文字,COLORFF00FF

VAR3AA赋值:如果(收盘价>1日前的收盘价),返回88,否则返回0

VAR4AA赋值:如果((收盘价)/(1日前的收盘价)>1.05)AND((最高价)/(收盘价)<1.01)AND(VAR3AA>0),返回91,否则返回0

当满足条件(VAR4AA>90)的45日过滤时,在(最低价)*(0.94)位置书写文字,画红色

当满足条件(VAR4AA>90)的35日过滤时,在(最低价)*(0.99000001)位置书写文字,画红色

Z1赋值:字符串相加

Z2赋值:字符串相加

Z3赋值:字符串相加

当满足条件是否最后一个周期时,在横轴0纵轴0位置书写文字,画黄色

当满足条件1时,在横轴0.88纵轴5位置书写文字,画洋红色

VAR6赋值:1日前的收盘价

VAR7赋值:收盘价-VAR6和0的较大值的6日[1日权重]移动平均/收盘价-VAR6的绝对值的6日[1日权重]移动平均*100

当满足条件82上穿VAR7时,在最高价*1.02位置书写文字,画黄色

VAR9赋值:((收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值))*(100)

VAR10赋值:VAR9的3日[1日权重]移动平均

VAR11赋值:VAR10的3日[1日权重]移动平均

VAR12赋值:VAR11的3日[1日权重]移动平均

A1A赋值:3*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*1的5日[1日权重]移动平均-2*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*1的5日[1日权重]移动平均,COLOR330066

A5A赋值:(60日内最高价的最高值-收盘价)/(60日内最高价的最高值-60日内最低价的最低值)*1

当满足条件A1A上穿A1A的5日指数移动平均ANDEMA(A1A,5)<A5A时,在最低价*0.98位置书写文字,画黄色

多赋值:收盘价的3日指数移动平均

空赋值:收盘价的5日指数移动平均

均衡赋值:空的5日指数移动平均

VVARF1赋值:统计2日中满足多上穿均衡的天数=1

VVARF2赋值:统计2日中满足空上穿均衡的天数=1

ZAI赋值:VVARF1ANDVVARF2的2日过滤

当满足条件ZAI时,在均衡*0.985位置书写文字,画红色

VV2赋值:1日前的收盘价

VV3赋值:(收盘价-VV2)的6日[1日权重]移动平均/收盘价-VV2的绝对值的6日[1日权重]移动平均*100

当满足条件1日前的VV3>81ANDVV3<80时,在最高价位置画2号图标

VF1赋值:收盘价的60日简单移动平均-收盘价的5日简单移动平均/3.2

VVARR1赋值:收盘价-1日前的收盘价和0的较大值的6日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的6日[1日权重]移动平均*100

当满足条件82上穿VVARR1时,在最高价位置画2号图标

当满足条件82上穿VVARR1时,在最高价位置书写文字,画黄色

VVAR1赋值:(最高价+最低价+开盘价+2*收盘价)/5

VVAR2赋值:1日前的VVAR1

VVAR3赋值:VVAR1-VVAR2和0的较大值的10日[1日权重]移动平均/VVAR1-VVAR2的绝对值的10日[1日权重]移动平均*100

HY3赋值:如果统计5日中满足VVAR3<20的天数>=1ANDCOUNT(VVAR1=10日内VVAR1的最低值,10)>=1ANDCLOSE>=开盘价*1.038ANDVOL>成交量(手)的5日简单移动平均*1.2,返回1,否则返回0

当满足条件HY3时,在最低价位置书写文字,画红色

ZA1赋值:收盘价的25日指数移动平均

ZA2赋值:ZA1的45日指数移动平均

ZB1赋值:收盘价的65日指数移动平均

ZB2赋值:ZB1的45日指数移动平均

DIFF赋值:(ZA1+ZB2)/2

DEA赋值:(ZA2+ZB1)/2

KA0赋值:(45日内收盘价的最高值-45日内收盘价的最低值)/45

KA1赋值:收盘价的3日[1日权重]移动平均

KA2赋值:收盘价-KA0*3的3日[1日权重]移动平均

KA3赋值:KA1-KA0*3的3日[1日权重]移动平均

SC赋值:100*(收盘价-收盘价的80日简单移动平均)

SC1赋值:SC的5日指数移动平均

SC2赋值:SC的21日指数移动平均

输出长期策略:SC1>=SC2,NODRAW

输出中期策略:DIFF>=DEA,NODRAW

输出短期策略:KA2>=KA3,NODRAW

输出中期趋势:DIFF,NODRAW

输出短期趋势:KA2,NODRAW

输出短期拐点:1日前的短期策略=0 AND 短期策略=1,NODRAW

输出长期趋势:ZB2,画蓝色,线宽为3

如果DIFF>=DEA,返回DIFF,否则返回无效数,线宽为2,画红色

如果DIFF<DEA,返回DIFF,否则返回无效数,线宽为1,画淡青色

如果KA2>=KA3,返回KA2,否则返回无效数画洋红色,线宽为2

如果KA2<KA3,返回KA2,否则返回无效数,线宽为1,画绿色

当满足条件是否最后一个周期时,在长期趋势位置书写文字,画淡蓝色

当满足条件是否最后一个周期时,在中期趋势位置书写文字,画红色

当满足条件是否最后一个周期时,在短期趋势位置书写文字,画黄色

程序源码

C2:=REF(C,1);

BG:=IF((C2-C)*100/C2>=2.3,1,0) OR IF((O-C)*100/O>=5,1,0);

BG2:=IF((H-L)*100/C2>=3.58,1,0);

BB1:=L< REF(L,1);

SELL1:=BG AND BB1 ;

BR:=IF((C-C2)*100/C2>=2.59,1,0) OR IF((C-O)*100/O>=4.5,1,0) OR IF((C-L)*100/L>5,1,0);

STICKLINE(BR,O,C,3,0),COLORRED;

DAY1:=BARSLAST(SELL1);

JIA1:=REF(O,DAY1);

JIA2:=REF(O,1);

BB4:=C>JIA2;

BB2:=H>JIA1;

BUY1:=BR AND BB2 AND BB4;

DAY2:=BARSLAST(BUY1);

S1:=DAY1< DAY2;

B1:=DAY2< DAY1;

STICKLINE(S1,O,C,3,0),COLORLIGREEN;

STICKLINE(B1,H,L,0,0),COLORRED;

STICKLINE(B1,O,C,3,1),LINETHICK2,COLORRED;

AA2:=AMOUNT/VOL;

BB3:=L< AA2*0.9;

CC2:=(C-REF(C,1))/REF(C,1)*100>1.2;

DD2:=L< MA(C,6)*0.921;

DD1:=L< MA(C,5)*0.921;

EE2:=VOL< MA(V,5)*1.5;

FF2:=BB3 AND CC2 AND DD2 AND EE2;

STICKLINE(FF2,H,L,0,0),COLOR00FFFF;

B4:=BARSLAST(FF2);

E4:=B4< 5;

F4:=E4 AND C>REF(C,1);

STICKLINE(F4,H,L,0,0),COLOR00FFFF;

A2:=(C-REF(C,1))/REF(C,1)*100< 1.02;

A3:=H>MA(C,5)*1.12;

AA:= A2 AND A3;

DRAWTEXT(AA,H*1.06,'*警'),COLORGREEN;

STICKLINE(AA,H,L,0,0),COLORFF0000;

VAR1:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)- 3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);

VAR2:=8;

CC:=CROSS(VAR1,VAR2);

CCC:=CROSS(VAR1,VAR2) AND H>REF(H,1) AND C>REF(C,1) ;

DRAWICON(CCC,L*0.99,1);

STICKLINE(CC,H,L,0,0),COLORRED;

STICKLINE(CC,O,C,3,1),LINETHICK2,COLORRED;

CF1:=BARSLAST(CC);

CF2:=CF1< 3;

CF3:=CF2 AND C>REF(C,1);

STICKLINE(CF3,O,C,3,0),COLORYELLOW;

CD:=CROSS(VAR2,VAR1);

STICKLINE(CD,H,L,0,0),COLORYELLOW;

STICKLINE(CD,O,C,3,1),LINETHICK2,COLORYELLOW;

DRAWTEXT(CD,H*0.93,'*预警'),COLORRED;

DRAWTEXT(CC,L*0.97,'*买'),COLORFF00FF;

VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);

VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)< 1.01) AND (VAR3AA>0),91,0);

DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.94),'*进 '),COLORRED;

DRAWTEXT(FILTER((VAR4AA>90),35),(LOW)*(0.99000001),'*加仓'),COLORRED;

Z1:=STRCAT(HYBLOCK,' ');

Z2:=STRCAT(Z1,DYBLOCK);

Z3:=STRCAT(Z2,' ');

DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORYELLOW;

DRAWTEXT_FIX(1,0.88,5,0,'~70822COM~☆~'),COLORMAGENTA;

VAR6:=REF(C,1);

VAR7:=SMA(MAX(C-VAR6,0),6,1)/SMA(ABS(C-VAR6),6,1)*100;

DRAWTEXT(CROSS(82,VAR7),H*1.02,'*警'),COLORYELLOW;

VAR9:=((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100);

VAR10:=SMA(VAR9,3,1);

VAR11:=SMA(VAR10,3,1);

VAR12:=SMA(VAR11,3,1);

A1A:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1),COLOR330066;

A5A:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*1;

DRAWTEXT(CROSS(A1A,EMA(A1A,5))AND EMA(A1A,5)< A5A,L*0.98,'*黑马'),COLORYELLOW;

多:=EMA(C,3);

空:=EMA(C,5);

均衡:=EMA(空,5);

VVARF1:=COUNT(CROSS(多,均衡),2)=1;

VVARF2:=COUNT(CROSS(空,均衡),2)=1;

ZAI:=FILTER(VVARF1 AND VVARF2,2);

DRAWTEXT(ZAI,均衡*0.985,'*追'),COLORRED;

VV2:=REF(CLOSE,1);

VV3:=SMA((CLOSE-VV2),6,1)/SMA(ABS(CLOSE-VV2),6,1)*100;

DRAWICON(REF(VV3,1)>81 AND VV3< 80,HIGH,2);

VF1:=MA(CLOSE,60)-MA(CLOSE,5)/3.2;

VVARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;

DRAWICON(CROSS(82,VVARR1),HIGH,2);

DRAWTEXT(CROSS(82,VVARR1),HIGH,''),COLORYELLOW;

VVAR1:=(HIGH+LOW+OPEN+2*CLOSE)/5;

VVAR2:=REF(VVAR1,1);

VVAR3:=SMA(MAX(VVAR1-VVAR2,0),10,1)/SMA(ABS(VVAR1-VVAR2),10,1)*100;

HY3:=IF(COUNT(VVAR3< 20,5)>=1 AND COUNT(VVAR1=LLV(VVAR1,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0);

DRAWTEXT(HY3,LOW,' *预警'),COLORRED;

ZA1:=EMA(C,25);

ZA2:=EMA(ZA1,45);

ZB1:=EMA(C,65);

ZB2:=EMA(ZB1,45);

DIFF:=(ZA1+ZB2)/2;

DEA:=(ZA2+ZB1)/2;

KA0:=(HHV(C,45)-LLV(C,45))/45;

KA1:=SMA(C,3,1);

KA2:=SMA(C-KA0*3,3,1);

KA3:=SMA(KA1-KA0*3,3,1);

SC:=100*(CLOSE-MA(CLOSE,80));

SC1:=EMA(SC,5);

SC2:=EMA(SC,21);

长期策略:SC1>=SC2,NODRAW;

中期策略:DIFF>=DEA,NODRAW;

短期策略:KA2>=KA3,NODRAW;

中期趋势:DIFF,NODRAW;

短期趋势:KA2,NODRAW;

短期拐点:REF(短期策略,1)=0 AND 短期策略=1,NODRAW;

长期趋势:ZB2,COLORBLUE,LINETHICK3;

IF(DIFF>=DEA,DIFF,DRAWNULL),LINETHICK2,COLORRED;

IF(DIFF< DEA,DIFF,DRAWNULL),LINETHICK1,COLORLICYAN;

IF(KA2>=KA3,KA2,DRAWNULL)COLORMAGENTA,LINETHICK2;

IF(KA2< KA3,KA2,DRAWNULL),LINETHICK1,COLORGREEN;

DRAWTEXT(ISLASTBAR,长期趋势,'*长期趋势'),COLORLIBLUE;

DRAWTEXT(ISLASTBAR,中期趋势,'*中期趋势'),COLORRED;

DRAWTEXT(ISLASTBAR,短期趋势,'*短期趋势'),COLORYELLOW;

注:

       馆内各种公式为学习编程而保存,实战使用前一定要看其中是否有未来函数并自己亲自测试成功率,决不能依据公式名称的描述和形容去投资,据此入市造成投资损失由投资者自己承担。

       发文不易,如获益,欢迎赞赏,赞赏必复!

本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报。